Error with openMalaria test


Advanced search

Message boards : Unix/Linux : Error with openMalaria test

AuthorMessage
Profile Conan
Avatar
Send message
Joined: Mar 24 09
Posts: 14
Credit: 231,387
RAC: 643
Message 18955 - Posted 26 May 2012 23:46:05 UTC

    Last modified: 26 May 2012 23:46:56 UTC

    Every openMalaria test work unit is failing with the following error
    openMalariaBeta_6.63_x86_64-pc-linux-gnu: /home/tino/devel/read_only_om/model/WithinHost/CommonWithinHost.cpp:131: virtual void OM::WithinHost::CommonWithinHost::update(int, double, double): Assertion `totalDensity == totalDensity' failed.
    SIGABRT: abort called
    Stack trace (14 frames):
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(boinc_catch_signal+0x5c)[0xc8e87c]
    /lib64/libpthread.so.0[0x3fc960f500]
    /lib64/libc.so.6(gsignal+0x35)[0x3fc9236285]
    /lib64/libc.so.6(abort+0x17b)[0x3fc9237b9b]
    /lib64/libc.so.6[0x3fc922ee9e]
    /lib64/libc.so.6[0x3fc922ef42]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(_ZN2OM10WithinHost16CommonWithinHost6updateEidd+0x3fd)[0x9c7681]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(_ZN2OM4Host5Human15updateInfectionEPNS_12Transmission17TransmissionModelEd+0xd9)[0x904dff]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(_ZN2OM4Host5Human6updateEPNS_12Transmission17TransmissionModelEb+0x98)[0x904e9e]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(_ZN2OM10Population7update1Ev+0x154)[0x8dfe68]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(_ZN2OM10Simulation5startEv+0x490)[0x8dc60a]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu(main+0x17b)[0x8d9dab]
    /lib64/libc.so.6(__libc_start_main+0xed)[0x3fc922169d]
    ../../projects/www.malariacontrol.net/openMalariaBeta_6.63_x86_64-pc-linux-gnu[0x8d9a19]

    openMalaria Branch A work units seem to work OK.

    Is it a problem with my 64 bit set up as the Branch A work units seem to be 32 bit.
    I have all the libraries that are mentioned in the error report.

    Conan
    ____________

    Post to thread

    Message boards : Unix/Linux : Error with openMalaria test


    Return to malariacontrol.net main page


    Copyright © 2014 africa@home