Problems connecting through proxy


Advanced search

Message boards : Web site : Problems connecting through proxy

AuthorMessage
Profile henry harya
Send message
Joined: Jul 14 06
Posts: 3
Credit: 101,031
RAC: 0
Message 1744 - Posted 4 Jan 2007 7:00:55 UTC

    Last modified: 4 Jan 2007 7:04:50 UTC

    Hi, I\'m trying to connect to the project from work where I am behind a proxy. Normally, I just need to give an application the proxy address/port, however I\'m receiving the following message:

    Scheduler request failed: Error 400


    When I manually enter my Windows domain username/password, I receive the following message:

    Temporarily failed upload of wu_12_127_21121_0_1180133755_0_0: HTTP proxy authentication failure


    I\'m sure that my username and password are correct. Any idea what\'s going wrong? Is the proxy blocking all communication with the project?


    ____________

    Profile maire
    Volunteer moderator
    Project administrator
    Project developer
    Project scientist
    Send message
    Joined: Nov 7 05
    Posts: 439
    Credit: 118,258
    RAC: 0
    Message 1747 - Posted 4 Jan 2007 9:36:32 UTC - in response to Message 1744.

      The BOINC client has had some problems with proxy servers in the past. The release notes for the current version 5.4.11 say:

      If you use a proxy server, please hold off upgrading for now. We have a fix in the works for proxies that use NTLM authentication

      I\'m not sure if this applies in your case, and if an older client version would solve the problem. If you want to give it a try, you can find older client versions here. Otherwise the next BOINC version may fix the problem.

      Nick
      ____________
      Nicolas Maire
      Swiss Tropical and Public Health Institute
      http://www.swisstph.ch

      Profile henry harya
      Send message
      Joined: Jul 14 06
      Posts: 3
      Credit: 101,031
      RAC: 0
      Message 1881 - Posted 11 Jan 2007 8:35:10 UTC

        Hi. Just to follow up on this, I never was able to connect through the proxy. I tried using all the available older versions as well as the development version with no luck. I\'ve come up with a work-around for now (routing through my cell phone periodically) but will try again when the NTLM-capable version is released. Thanks!
        ____________

        cborella
        Send message
        Joined: Jun 21 06
        Posts: 1
        Credit: 512,216
        RAC: 72
        Message 2307 - Posted 7 Mar 2007 8:42:56 UTC

          Hi, I\'ve had the same problem in the past; and the latest version of BOINC I\'ve found working flawlessly through an NTLM authentication-firewall is the 4.24.
          I\'ve recently upgraded to 5.8.16, but it shows a 400 Error from time to time, and I will rollback to 4.24 one of these days.
          CÚdric
          ____________

          Profile henry harya
          Send message
          Joined: Jul 14 06
          Posts: 3
          Credit: 101,031
          RAC: 0
          Message 2376 - Posted 16 Mar 2007 9:37:43 UTC - in response to Message 2307.

            I haven\'t had any luck with any version of BOINC. I\'m actually wondering if anyone out there has had any luck using NTLMAPS with BOINC.

            I\'ve been trying to use it and it behaves strangely. I can connect to my BAM account manager without a problem. However, whenever I try to upload my WU\'s it always seems to hang midway. I\'ve tried modifying the client header and using basic NTLM authentication to no avail.

            Anyone out there know how to solve this?

            ____________

            Profile JLDun
            Send message
            Joined: Feb 2 08
            Posts: 112
            Credit: 5,402
            RAC: 0
            Message 5336 - Posted 17 Feb 2008 4:37:05 UTC - in response to Message 2376.


              Anyone out there know how to solve this?

              Version 5.10.4x is in testing now, with Proxy one of the issues to be corrected.
              ____________

              Profile Crazybob @ SETI.USA
              Send message
              Joined: Oct 22 07
              Posts: 4
              Credit: 12,251
              RAC: 0
              Message 5421 - Posted 21 Feb 2008 14:20:29 UTC - in response to Message 5336.


                Anyone out there know how to solve this?

                Version 5.10.4x is in testing now, with Proxy one of the issues to be corrected.


                I used to use version 4.45 and this worked, but now some projects won\'t except it. I\'m currently using 5.8.15 and so far it acceptable with some quirks. Haven\'t tried the newer versions yet.

                ____________

                Post to thread

                Message boards : Web site : Problems connecting through proxy


                Return to malariacontrol.net main page


                Copyright © 2014 africa@home